If you're posting a request for installation help, please provide as much info about your system as possible. For example, for help regarding connecting a smart thermostat, please include details about your system including whether you have gas/electric, heat pump, number of heat stages, A/C condenser, etc.

SmartRecovery question (start cooling early)

cullenmicullenmi MIMember

I have an ecobee 3 in a 2 story home where the upper story is consistently 4-6 degrees warmer than the main floor. My remote sensor is in the upstairs bedroom.

During the main course of the day ('Home' comfort setting), I want the cool point to be at 72 degrees (both sensors on).

When I go to bed ('Sleep' comfort setting) i want the cool point to be 69 degrees, considering only the upstairs sensor.

I have this set up as written above. The problem is cooling it down by the time I get to sleep. At 9:45pm the upstairs might be 75 degrees (taken as half of the 72 degree average), and at 10pm the system switches to 'Sleep' and it needs to bring the upstairs down a full 6 degrees. I have Smart Recovery enabled for both heating and cooling, but the system does not seem to begin cooling to any significant degree until 10pm. I've been manually setting the cool point down to 68 or 69 starting at 9pm as a way of getting the cooling started early enough so that it is comfortable when I am ready to go to bed.

Is there a better way to make this work, or should I just add an additional comfort setting as an intermediate point between 'Home' and 'Sleep'?

I've only had the system active for 3 or 4 days, so it may not have had time to fully optimize, if that makes a difference.

Answers

  • gpzbcgpzbc Colorado, USAMember

    I think your issue is related to the bug described in the thread below. Basically, 30 minutes prior to the next comfort setting, the ecobee starts taking into account the sensors scheduled to participate in the next comfort setting, but it is not taking into account the temperature of the next comfort setting. This becomes a problem when the next comfort setting temperature is a large setback.

    In your case, the ecobee is probably averaging all of your sensors starting at 9:30. Your downstairs is cooler and is skewing the average. And it is not until 10:00 when the ecobee switches to the Sleep comfort setting that it only accounts for the sensors upstairs. And that is when it realizes that it needs to cool down to 69 degrees. The way it should work is that Smart Recovery should essentially ignore the downstairs sensors starting at 9:30 and begin cooling the upstairs to 69 degrees.

    If you download your Home IQ logs into a spreadsheet, you can use a few "average functions" to calculate which sensors the ecobee is utilizing to determine the set temperature.

    Does that make sense? Check out the thread here. It may to be a slightly different issue because we are all talking about the Heat setting while you are talking about the Cool setting, but I think it is the same bug.

    http://www.smarthomehub.net/forums/discussion/760/peculiar-behavior-smart-recovery-bug#latest

  • cullenmicullenmi MIMember

    Interesting - that does make sense. Thank you for the info.

  • MikeyAMikeyA TorontoMember

    Hey @cullenmi try scheduling the sensors so only the updates sensor will be the primary sensor for the Sleep period. It will then know it's switching sensors for temperature reading from both to only 1 and possibly start the Smart Recovery process earlier.

    You can do this by going into the Main menu of the thermostat then select Sensors. Then select the Main Thermostat and choose Participation. Un-select all the comfort settings except for Sleep. The thermostat now knows to only read from the sensor during the Sleep comfort setting and not read from the Main Thermostat. I hope this information helps!

Sign In or Register to comment.