If you're posting a request for installation help, please provide as much info about your system as possible. For example, for help regarding connecting a smart thermostat, please include details about your system including whether you have gas/electric, heat pump, number of heat stages, A/C condenser, etc.

Peculiar Behavior (Smart Recovery Bug?)

2»

Comments

  • nhatmannhatman SoCalMember

    That's a good idea. But what a pain in the butt! I have quite a few transitions from downstairs to upstairs throughout the day.

    I'm trying another work-around right now to see if it works. I suspect this happens only when transitioning to and from the default Home comfort setting. So I created another comfort setting to replace the default Home. We'll see...

    And while I'm at it (complaining, that is), I would also LOVE to see the ability to manually select a comfort setting to override the schedule. Or manually select a temp and participating sensors when overriding the schedule.

    Thanks for your help, gpzbc!

  • gpzbcgpzbc Colorado, USAMember

    Keep us posted on whether or not your workaround works. Without any testing, it seems like the bug is always present when coming off of the Home comfort setting for me too.

    And yes, I agree that it would be great if you could manually select a temp and participating sensors when overriding the schedule. That exact feature has been requested and discussed in this thread

    http://smarthomehub.net/forums/discussion/880/manual-adjustment-overriding-remote-sensor-selections#latest

  • nhatmannhatman SoCalMember

    Never mind. My workaround (creating a different "Home" comfort setting) didn't work. I have smart recovery off (along with all other smart features) and this damn thermostat is still averaging the current and next comfort setting sensors but only using the current comfort setting temp. This makes absolutely no sense whatsoever!

    With smart recovery off, I just want this to immediately switch to looking at the next comfort level sensors and applying the next comfort level's temp. How hard can that be? What a total waste of energy and it's overheating the upstairs unnecessarily. With this current bug, I would unfortunately never recommend this thermostat to anyone.

  • gpzbcgpzbc Colorado, USAMember

    I understand your frustration. I really do. Try setting up the following workaround and I bet it will work for you.

    Leave Smart Recovery enabled.
    Create a new comfort setting called "Nap Fix". If your Nap Time comfort setting starts at 1:00 pm, then start your Nap Fix comfort setting at 12:30. Set the desired temperature of the Nap Fix setting to 68 degrees, and tell it to only watch the Living Room and Dining Room sensors during Nap Fix. Then you run "Home" until 12:30, Nap Fix from 12:30-1:00, and Nap Time at 1:00.

    I think you will find that gives you your desired results.

    lannister80
  • gizbuggizbug ChicagoMember

    Has Ecobee fixed this yet?

  • gpzbcgpzbc Colorado, USAMember

    I haven't seen any progress towards a fix yet. Maybe @mikeya can chime in on the progress?

  • LarryM61LarryM61 USAMember

    I too, would like to know...

  • I can confirm ecobee have NOT fixed it nor do they seem willing to accept that there's an issue. I have reported this exact fault several times and told different BS answers.

    lannister80
  • Any updates now? I'm on 3.7.0.910 and also have this bug. My AC comes on every morning shortly before transition between sleep and home mode despite the transition being to a slightly warmer temperature.

  • gpzbcgpzbc Colorado, USAMember
    edited August 2016

    I guess the more people that report it to Ecobee Support, the more likely they are to fix it. These forums are not enough. I'm not even sure that these forums are consistently monitored since it is not an official ecobee forum.

  • nhatmannhatman SoCalMember

    Now that it's starting to get cooler in SoCal, the heater is back on. And I see this SUPER annoying bug has not been fixed! I am a gadget nerd and like to support new ground-breaking consumer electronics, but so far, I cannot recommend the Ecobee to any of my friends or family. As I'm sitting here, it's transitioning to "bedtime" which means 66F downstairs where both sensors are averaging 69F. But the stupid thing is turning on the heat because even though it hasn't changed the comfort setting yet (the current is set for 72F for upstairs), it's taking into account the downstairs sensors, artificially decreasing the temperature.

    So now I'm burning up upstairs and wasting energy. I don't know how much more of this I can take. The workaround is annoying to have to implement and takes some time to get working right. It's been almost a year and this hasn't been fixed yet!

  • vajimvajim VirginiaMember

    anybody call ecobee ???

  • fpuigfpuig East CoastMember

    Since last year I disabled smart recovery for cool and heat and looks like my E3 behavior is better.

    Paging: @MikeyA @CaseyEcobee

  • gpzbcgpzbc Colorado, USAMember

    I had several conversations with Support and nothing has come of it. I'm frustrated for sure. In the meantime, I just continue to use the workarounds. I really don't want to disable smart recovery because I really like it when it is working correctly.

  • bukzinbukzin CaliforniaMember

    I am sure there are a few other user forums (what are they?) for Ecobee stats.

    Do you think Ecobee watches any of them?

    I'm new to Ecobee; regarding bugs and revision requests is this what I should expect moving forward?

    Thx

  • EDubsEDubs Member

    Just confirming that the Transition Period issue is still an ongoing problem. I spoke with a low level tech support person yesterday who did not seem to understand the issue. They would not connect me to a manager, they just said the managers would take a look at the logs. Sigh. FWIW, I have Smart Recovery disabled and the bug was present, so I did the suggested workaround (thanks for the workaround, BTW!). I'll report back here if I hear anything from them.

  • gpzbcgpzbc Colorado, USAMember

    This bug still appears to be present me. Although I can't be certain because I have the workarounds in place.

  • kevinmcckevinmcc Macomb, ILMember
    edited March 5

    Ecobee so needs a Bugzilla page... Been requesting one for ages... Deaf ears over there, I swear...

    gizbug
  • gpzbcgpzbc Colorado, USAMember

    Agreed! It's frustrating. I find it easier to deal with bugs if I know that they are working on a fix, or that it is at least on their radar.

  • towprotowpro Member
    edited March 6

    the bug is also in the Smart thermostat.

    Sounds like the same problem your having. During recovery periods it will not use stage 2, but once your through that period stage 2 will follow my setting of "max stage 1 run time 10 minutes" every time.

    Ecobee had me turn off smart recovery, no difference. we did a "re-learn", no difference.

    I did an experiment and left program periods Sleep, Morning, Day, evening and changed it to the first 3 periods are all 66, then evening is 68. Still, when you come to around the time schedule for Sleep to transition to morning, even though the temps are set the same, it will will stick to stage 1.
    On my system stage 1 is 24K btu, stage 2 is 36K btu and stage 3 is 48K btu (gas). I also have stage 4 (72K btu) but it never comes on.
    my compressor lower temp cutout is 30 deg. at 30 deg, 24K btu is not enough and I have seen heater run for 90 minutes or more.

    I been going around and around with engineering and QC since November.
    Last think they said was Stage 2 temp delta takes priority over max stage 1 run time.
    I changed temp delta to auto and during recovery periods, it still sticks to stage 1.
    Even setting both to auto I have seen over 90 minutes stage 1 run time in the morning.

    last week they finally told me "this is how its designed, and we can't fix it because its not broke, plus the smart is end of life".

    The kicker is the previous version of code worked perfect. when they informed me they were done with me I asked if they would move me back to the older software. (I know they can because I had it moved back in November. in late December Engineering got involved and moved me back to current firmware.

    Tomorrow is a week since last correspondence, so I need to call and get it moved back.

  • gizbuggizbug ChicagoMember

    Support seems to be trending towards the worse lately

    vajim
  • towprotowpro Member

    I sense they know there is a problem with the code across the board, but are not allowed to admit it.

  • vajimvajim VirginiaMember

    how many users have stage 2 heating systems?

  • lsbrodskylsbrodsky New Bern, NCMember

    I suspect in today's more energy aware users, there are plenty. The low-first-cost equipment base is single stage but my dealer sells more 2 stage today.

    vajim
  • ianjrcianjrc San MateoMember

    man, I'm experiencing this same issue described here and it's SO annoying. Sad to hear that Ecobee doesn't care to fix this blatant bug.

    We have Sleep Mode (kids room sensor) set to 68 degrees, and then at 7am Away Mode (kitchen sensor) takes over at 60 degrees. Around 30 minutes before transition the heat kicks on because the average of the two rooms drops below 68 degrees EVEN though both rooms independently are above their set temps. The kids room was measuring 68 degrees (and set to 68 degrees), and the kitchen was measuring 64 degrees (and is set to be 60 degrees at 7am) - the average of the two rooms was displaying 67 degrees (below the Sleep Mode setting of 68), kicking on the heat. No heat was needed!

    I was planning on calling Ecobee this week to get support, but sounds like many people here have attempted that with no success. So disappointed!

  • gpzbcgpzbc Colorado, USAMember

    If you have time, it can't hurt to have one more person bring this to the attention of support.

Sign In or Register to comment.