If you're posting a request for installation help, please provide as much info about your system as possible. For example, for help regarding connecting a smart thermostat, please include details about your system including whether you have gas/electric, heat pump, number of heat stages, A/C condenser, etc.

Official ecobee3 HomeKit Feedback Thread

2456

Comments

  • SteveSteve Seattle, WAAdministrator

    It's not the "range" that's the issue, it's the fact what when I'm at 76F and I ask to lower it by 2, it attempts 50F!! :)

    briansusername
  • mustang_52mustang_52 United StatesMember

    I notice with my homekit e3 that in home iq, it's showing the fan runtime. I have my fan set to hvac and it didn't graph the fan because the ecobee wasn't controlling it. Is this maybe only in cooling mode and not in heating mode or a new feature?

  • REOScorpioREOScorpio Lisle, ILMember

    Has anyone been able to use their apple TV to change settings on the Ecobee when away from home? I could have sworn it worked at one point, but now Siri tells me that "I was not able to do that" or that "Devices are uninterested". I've tried Apple's one suggestion of signing out of my apple ID on the apple TV, but it did not help.

  • dannykott9dannykott9 USAMember

    REOScorpio said:
    Has anyone been able to use their apple TV to change settings on the Ecobee when away from home? I could have sworn it worked at one point, but now Siri tells me that "I was not able to do that" or that "Devices are uninterested". I've tried Apple's one suggestion of signing out of my apple ID on the apple TV, but it did not help.

    First step I would do is make sure that the Apple TV software is up to date. If it is, then you can try resetting the HomeKit connection on the Ecobee. On the actual thermostat, it's under settings. Then you'd have to re-add the thermostat to your home. I've had to do this a couple times when things stop working.

  • @REOScorpio I just tried five times and Siri kept saying, "Sorry, I was not able to do that." Then I launched the ecobee app and tried again. Siri immediately complied with several different commands. Interesting...

    Should also tag @msaleem so he knoes what's going on in the wild :-)

  • REOScorpioREOScorpio Lisle, ILMember

    @briansusername Strange. I get the "Sorry, I was not able to do that." each time. So, you opened the app, then just relaunched siri and repeated the commands? Just tried but didn't work for me.

    @dannykott9 Thanks for the suggestions. However, I think I've reset the HomeKit and added it back five or six times already since opening the new thermostat :)

    Ah, the joys of a fledgling product and software combination.

    Thanks to both of you for the help.

  • @REOScorpio said:
    So, you opened the app, then just relaunched siri and repeated the commands? Just tried but didn't work for me.

    Yeah, I launched the app, (I think) clicked on my thermostat to get to the thermostat main screen, then (without leaving the app) held the button down to launch Siri to tell her to set my thermostat to 82 degrees. She confirmed that she set it to 82.1 degrees :-) and that showed up in the app, too, after going to settings and back to refresh the screen.
    (And just to make sure this is clear, I'm not home and am on a cell connection now)

    Ah, the joys of a fledgling product and software combination.

    Yes, it is a bit of an adventure. I figure that's the price we pay for living in the future...or at least on the brink of the future ;-)

  • REOScorpioREOScorpio Lisle, ILMember
    edited July 2015

    So, tried resetting homekit one more time and it wouldn't add home kit back. It sees it, but I get and "Error Communication Failure". I tried doing a full reset and still nothing. Tried a different ios phone, tried resetting configuration as well. No luck.

    Had to remove ecobee from wall after resetting it, kill power at the breaker, and reset router. Then, set everything up and it worked. I'll post back on whether or not it works away from home as soon as I can.

    Thanks again.

  • REOScorpioREOScorpio Lisle, ILMember

    @briansusername no luck. Still does not work outside of home. I get the "Sorry, I'm unable to do that" error.

    At this point, I'm thinking it has something to do with my network but I don't know any settings that would have restricted outside access to the Apple TV

  • @REOScorpio I tried again later and got the "Sorry" response. I tried my start up the ecobee app trick and it didn't work. Oh well, could have been a coincidence before :-)

    Hopefully iOS 9 will improve remote access, even if Apple TV access remains flaky.

  • briansusernamebriansusername UtahMember
    edited July 2015

    @REOScorpio Just had a thought - my AppleTV is usually sleeping when I'm away. I wonder if that makes a difference...

    Maybe I'll try disabling sleep on the Apple TV to see if that makes a difference.

  • REOScorpioREOScorpio Lisle, ILMember

    @Briansusername I had the same thought and tried today. Worked for a while, then stopped. Logged out and back in on the Apple TV, worked for a bit, but wasn't working later.

    Definitely an intermittent problem, but I can't quite pin down any variables that cause it. Always works around the house though.

  • @REOScorpio Interesting, I just tried the opposite test and it unexpectedly worked:

    I made sure my Apple TV was asleep (no LED on and the TV complained of no input), switched off WiFi to use LTE, and still was able to set my thermostat to 82 degrees (confirmed by checking the thermostat screen). I thought the Apple TV might wake up to do this, but it didn't.

    Of course, it did reject two commands to list the temperature before succeeding in setting the temperature. Oh well. I guess I'll not expect too much for now :-)

  • dannykott9dannykott9 USAMember

    Anyone have any luck setting up rooms/zones? I tried to make a room called "Office" and it gave me an error saying "Object with similar name exists in home." I thought this might be because I have a sensor with the name "Office," so I changed the name of that sensor. Even after that change, I still get the error message when I try to add the "Office" room. Do I need to re-pair the sensors and give different names? Rest HomeKit configuration?

  • @dannykott9 I don't think the rooms/zones have anything to do with ecobee or the econee3. That's all HomeKit stuff. I thought I'd be able to assign a sensor to a room/zone, but they just don't fit together like that (maybe iOS 9 will open up some options like that?).

    That being said, I did set up zones and rooms in that HomeKit section and didn't have any problems. They just don't do anything for me since I only have one HomeKit device (the e3), and it is just assigned to the entire "Home."

    I would think that error message should only be saying there is another "room" in your HomeKit setup that has a name that Siri would confuse for "Office". You might try out the (free) Elgato Eve app, which has a pretty comprehensive HomeKit interface. Maybe you'll get different results there.

  • dannykott9dannykott9 USAMember

    @briansusername thanks for the response. I'll give the Elgato app a try. Just curious, what do you use for your sensor names? Are they the same as any of your rooms? And if so, does the Siri command "List my [sensor name] temperature" work for you to get temperature in a specific room?

  • briansusernamebriansusername UtahMember
    edited July 2015

    @dannykott9 said:
    Just curious, what do you use for your sensor names? Are they the same as any of your rooms? And if so, does the Siri command "List my [sensor name] temperature" work for you to get temperature in a specific room?

    I have one sensor that is named the same as a HomeKit room. The "List my..." command doesn't work for that sensor, with Siri saying, "Sorry, I can't find any devices in that room" (or something like that). The other rooms have similar but different names (e.g. "Bedroom" sensor name but "Master Bedroom" HomeKit room name) and they work.

    I'll probably change the name of that room or sensor so Siri doesn't get confused.

  • dannykott9dannykott9 USAMember

    @briansusername ok, I'm running into the same issue. I'd be interested to hear if the command starts working after you change the room name. In my experience, it hasn't. I may just end up deleting and re-pairing the sensors and renaming them completely different than my room names.

  • @dannykott9 I renamed my HomeKit "Dining Room" to "Dinner Room" and then deleted the room from HomeKit. I still can't access my "Dining Room" e3 remote sensor via Siri.

    When I ask Siri about the "Dining Room" or "Dinner Room," she capitalizes both (even after deleting the room), like they are still HomeKit rooms. I assume that they will eventually fall off the HomeKit/Siri cache and I will be able to access my "Dining Room" sensor as intended.

  • dannykott9dannykott9 USAMember

    That's what I'm hoping as well. Because I did the same thing with my "Office" room, and now, since I previously deleted the room, I am unable to add it back. For some reason it's still in the cache despite deletion and resetting HomeKit configuration.

  • areavareav United StatesMember

    Hi, I was able to get my iPhone to work with home kit, but for some reason I am not able to get my iPad. It is telling me "wasn't able to find any thermostats" any ideas?

  • This may help some folks… I found out that the ecobee3 does not support 5 GHz wi-Fi connections… only 2.4 GHz. Mine is still not working outside of my home network but I thought I would pass this tidbit of info along.

  • dx9dx9 CanadaMember

    I even loaded iOS 9 beta 2 and remote access doesn't work.

  • GaryGary Member

    Im lost. My ecobee 3 wont stay paired to my app and or homekit. Yesterday the Ecobee tech just walked me through setting it up again after pressing reconfigure home kit choice on the thermostat. It worked fine. To day i go to check and its back to not working with siri. Siri dose not see a device. My rooms zones and echobee show in the ecobee app but when i press done to get out of that screen i get this pop up screen

    Your echobee 3 is not reachable. Please check to of if it is paired to your app correctly and try again.

  • GaryGary Member
    edited July 2015

    Well now Siri recognizes my thermostat is there and I no longer get the pop-up screen error. It must be on the Apple Siri or homekit side. I woukd like to find out if anyone has any ideas.

  • I can't seem to have HVAC setting involve both AC and heating on an auto setting when I am using the device in HK. I have to choose AC or heating? I removed HK and no improvement.

  • fpuigfpuig East CoastMember

    Anyone had luck accessing their E3HK remotely, using siri out of the WiFi network?

  • @fpuig said:
    Anyone had luck accessing their E3HK remotely, using siri out of the WiFi network?

    I've had some luck, yes, which sounds like what it takes right now. I logged out of iCloud on my Apple TV and logged back in and remote Siri access works often, but not always. Sometimes it takes a couple of tries (e.g I ask for the temperature twice in a row - the first fails and the second succeeds).

    Sounds like the flakiness is likely on Apple's end. Hopefully It will get better as HomeKit matures:

    http://www.macrumors.com/2015/07/31/elgato-eve-smart-home-homekit-accessories-review/

  • @escottr said:
    I can't seem to have HVAC setting involve both AC and heating on an auto setting when I am using the device in HK. I have to choose AC or heating? I removed HK and no improvement.

    For some reason Apple doesn't allow a HomeKit thermostat to be in Auto mode. My guess is that they didn't build in programming and Siri hooks for setting a Cool set point vs a Heat set point. Maybe they didn't think about it or maybe they decided that was a bit too complicated until Siri's natural language processing gets better.

    Here's how ecobee said to get Auto mode back (removing HomeKit):

    step 1: remove the ecobee3 accessory on the iOS device (if connected on the same wifi) or go to Settings > Reset > Reset Homekit

    step 2: on the thermostat: Settings > Installation Settings > Thresholds > Auto Heat/Cool > Enable

    Source:

Sign In or Register to comment.