If you're posting a request for installation help, please provide as much info about your system as possible. For example, for help regarding connecting a smart thermostat, please include details about your system including whether you have gas/electric, heat pump, number of heat stages, A/C condenser, etc.

ecobee 3 constant clicking (and doesn't light up) with Carrier Infinity 59TN6A furnace

patspats burlingame, CAMember

PROBLEM: When I connect the Ecobee to the Infinity I get constant clicking and the thermostat does not light up. If I switch the RC wire to RH per ecobee's suggestion, I get no clicking, the device still does not light up but after a few seconds the fan goes on, but no heat. That indicates to me that some power is going through.

CURRENT USE: First I currently have a single stage, old Enerstat thermostat that only contains the following wires: RC/RH with Jumper, W and G. For the Carrier: I don't have air conditioning, and I don't have a dehumidifier. So it's a pretty simple system. Just heat.

I set up the Ecobee as follows:

RH -- > R (red)
W1 ---> W1 (white)
G--->G (green)
C--->C (Blue, 24 v)

I set the dip switches as follows:
SW1 1 off
SW1 2 ON
SW1 3 OFF
SW1 4 ON
SW 1 6 - OFF
SW1 7 and 8 OFF (should it be on?)
SW4 2 - ON

RESULT: Constant clicking, nothing going on. Switch to RC: No clicking but fan goes on.

I tried using different wires to connect to the C (there is a bundle in the wall.) I don't think there are any problems with the wires.

When I spoke with Ecobee they apologized for the problems with the Inifinity and basically said it isn't a good system for the Infinity, but no contraindicated. We have tried everything -- cross testing wires and touching them in various configurations and the heat powers on. (I cannot remember all the iterations I used.)

At first I thought it was a problem with the thermostat so Ecobee sent me a new one. SAME THING.

What could be the problem? Could it be a problem with the C terminal? The dip switches? Should I just chuck this thing?

Thanks!

Patricia

Comments

  • kevinmcckevinmcc Macomb, ILMember
    edited December 2017

    You possibly have a weak transformer. Have you tried measuring the voltage with as multi-meter? Try disconnecting putting a wire nut on end of W and a wire nut on end of G so they don't touch each other. Leave them disconnected and then connect the Ecobee? Clicking? Does the Ecobee light up?

    Which model is your furnace?

  • BarkencyBarkency Toronto, ONMember
    edited December 2017

    (EDIT: my response assumed a working ecobee but non-working furnace) The W1 from the ecobee has a compatibility problem with some furnaces. The W2 has better compatibility and there is a way to use W2 instead with these instructions that ecobee support gave me and others:

    Switch the W1 wire to W2. Then in the settings you reconfigure the wiring to tell it it has a W2 and a W1, even though there’s no W1. In thresholds, set the stage 2 delta to 1°F and the stage 1 max runtime to 10 mins.

Sign In or Register to comment.