If you're posting a request for installation help, please provide as much info about your system as possible. For example, for help regarding connecting a smart thermostat, please include details about your system including whether you have gas/electric, heat pump, number of heat stages, A/C condenser, etc.

Something changed since last winter (firmware?) EB‑STAT‑02

towprotowpro Member
edited November 2016 in ecobee

Ecobee Smart EB‑STAT‑02. 4 heat/2 cool. Heat pump compressor is stage 1 and 2. Aux Gas is stage 3 and 4.
RSM board running external temp, bedroom temp (used to average between thermostat), Duct temp, return temp (they were there so I used them) Humidifier and an alarm relay on condensate pump.
Stage 1=24K btu, 2=36K btu, 3=48K btu, 4=80K btu (never seen stage 4 come on)

I am having problems regulating when stage 1 changes to stage 2.

settings:
Installation settings, Thresholds, advanced,
Reversing stage is set to "NO"
Stage 2 temp delta is set to "2"
Stage 1 Max Run time is set to "X"
(manual says The maximum amount of time stage 1 will run before engaging the next state. options are auto (default and 10 to 120 minutes)

In summer I set stage 1 max run time X to auto. This allows thermostat to control switch from 1 to 2. Most of the time my AC never even goes to stage 2, causing longer run times which helps dehumidify.

In winter I set stage 1 max run time X to 10 or 15 min.
Problem is this year when I change the X setting to 10 minutes, the first couple times the heater cycles it runs stage 1 for 10 min, then switches to stage 2.
But than after a while the data shows the heater never advanced to state 2 after 10 minutes.
Yes I am exiting out of thermostat, and settings are saved. I even rebooted it last night.

I made the change yesterday afternoon. Last night it dropped below 30 so AUX (stage 3) was my heat source.

looking at today's data:
9:20 am, stage 1 ran 25 min.
10:05 am stage 1 ran 30 min.
10:55 am stage 1 ran 20 min.

I swear this worked last year, what am I doing wrong?

Comments

  • last night tried X = 15 min. At times the stage 1 ran for 50 min, never advances to State 2.

  • So did it got from Stage 1 to Stage 3?

    Could be wiring or faulty relay if stage 2 did not run.

    Could be a bug, I'd call Ecobee support.

  • towprotowpro Member
    edited November 2016

    its not wiring or relay.

    I just viewed my data for last 3 days. on both 11/24 at 10:30 and 11/25 at 11:00 am I manually changed thermostat up 2 deg because it was in away mode and we were home on vacation.
    Since my Stage 2 temp delta is set to "2" At that point State 2 came on.

    But never any other time stage 2 come on. at times state 1 will run for over 1/2 hour, but it only advanced to state 2 if there is 2 deg difference between actual and set temps.

    Maybe I am not changing this is in correct place, but it sure sounds like it when I read the description.

    and the HVAC system is sized correct so the only time it will need to advance to state 3 (gas) is when I hit the outside temp when I decided to turn off the compressor heat.
    my system should be able to work down into the 20's on Compressor heat stage 2, but its more efficient to use Gas at those temps.
    (but with Ecobee refusing to switch from stage 1 to stage 2 (worked last year and I have data to prove it), there goes some of my efficiency).

    I have done manual J calculations on building and know heat gain/loss because I was thinking of putting in Geo Thermal. (I already have the well I need) But payback on Geo Thermal is so long someone in there 50's will never see it.

    EDIT: I have called Ecobee, but all they did was verify I was making the change in correct place, and the said something that made me think new firmware came out during the summer: changes were something like "house keeping" or something I was told.

    I also just tried switching back to 4 temp profiles instead of 5.

  • towprotowpro Member
    edited November 2016

    How it currently works. (right click, view images worked for me in firefox).

    which looks like this (see how long my stage 1 runs) you will see stage 2 coming on a couple times (darker red) but that is because my stage 2 temp delta is set to 2, and that was a 2 deg temp change request.

    How it worked last year.

    which looks like this (see how stage 1 only runs 10 min, than stage 2 finishes the job quick)
    outdoor temps might be higher in one graph, but still, it shows stage 2 coming on.

  • The supposedly did a entire code rewrite to make editing easier. I wonder if they made some mistakes. I would see what support says.

  • around 2:00 this afternoon they rolled me back to 2.1.0.256, its working perfect since.

    but it was warmer today and 10 minutes of stage 1 can satisfy the heat requirements. There was a couple times this evening it went past 10 minutes and it jumped right up to stage 2 :). I will let it go a day or so to see the results and update here.

    kevinmcc
  • after being on hold with Ecobee for 1 hour and 29 minutes I got to follow up with them. :(

    after explaining my problem all over again to someone different, he saw the last persons note on my account that they moved my firmware back to 2.1.0.256.
    I told them "Now that its colder, I see my Stage 1 max run time is working as expected." So this is telling us (me) that something is wrong with 3.3.0.696.
    he proceed to tell me I am the only one affected with this problem :-q
    "you really don't expect me to believe nobody else is running 2 stage heat?"

    I asked how do we proceed? He offered to lock my thermostat code version. I asked if maybe they could fix the new code than apply it to my thermostat?

    I asked for a response, from anybody, telling me if they were going to lock my code, or fix the new code.

  • You can't be the only one with this issue. I'd ask to talk with an engineer, some times you need to speak with tier 2 or 3 directly.

  • towprotowpro Member
    edited December 2016

    but how can I get to that level? it takes 1.5 hours to get to first level, and he was not going to let me talk to anybody else. I am very frustrated now.

    If have almost $400 tied in in this setup, plus my labor wiring it.

    I just discovered the code they moved me back to really don't work with the phone app. I am sitting here listening to state 2 compressor run, but phone says no equipment is running.

  • @towpro said:
    but how can I get to that level? it takes 1.5 hours to get to first level, and he was not going to let me talk to anybody else. I am very frustrated now.

    If have almost $400 tied in in this setup, plus my labor wiring it.

    I just discovered the code they moved me back to really don't work with the phone app. I am sitting here listening to state 2 compressor run, but phone says no equipment is running.

    Email would be your best bet, they have access to your data and can check other peoples data too.

  • towprotowpro Member
    edited December 2016

    another call today.
    I found that the Tech who rolled me back to 2.1.0.256 on 11/28 turned in a ticket to Engineering.
    all I can do is wait.

    kevinmcc
  • Caprice96Caprice96 WinnipegMember

    Hi towpro

    I've been having a similar issue. My thermostat is doing the same thing (running stage 1 for longer than the set max time). However, mine does it only periodically. Sometimes it works as set (stage 1 runs for 40mins, then stage 2 for 20mins and then aux). Was yours working correctly periodically before you had the firmware switched?

    I called into Ecobee this morning from work and they tried to help, but since we have internet only through our phones (and the phones weren't at home) the thermostat wasn't connected to the internet. They suggested I turn off smart recovery, which I will try tonight. I'm not sure if this will work or not since we have ours set to hold indefinitely and don't use the schedule.

    I emailed their support after the phone call and referenced the thread you created and asked that my ticket get added to a master ticket (if there is one).

    Did they ever get back to you with a solution?

  • Mine was only a problem with Stage 1 to stage 2 in 10 minutes.
    stage 1 would run for over an hour at times. Yes some times it would advance to stage 2 but I feel that was because I had stage 2 temp delta set to 2 deg.

    Mine had nothing to do with smart recovery either. smart recovery would apply to when your recovering from a heat offset. mine was doing it every time the heat came on, even in the middle of a period. it would run stage 1 for sometimes an hour before stage 2 would come on. I would bet now that its colder stage 1 might be running for hours?

    My stage 1 and 2 are heat pump. Stage 3 is propane. I have thermostat set so at 30deg heat pump stops and gas comes on. my stage 2 will still heat house below 30f. but I feel that is the point where propane becomes more efficient where I live.

    I called them again yesterday. I got the same guy that moved my code back to old version. I told him yes it is working perfect since they moved me back to version 2.1.0.256. but now the portal and phone app never show that any equipment is running.
    I asked if he had any info about my ticket. he was going to talk to coworkers and email me back. Still heard nothing.

    One of the techs sort of implied this was only affecting me or he had not heard anybody else having this problem. I say BS!
    I guess nobody is calling it, or they end up hanging up instead of waiting on hold for 45 minutes or more, and ecobee never hears about this problem.
    There has to be others out here with the same problem, glad you called in to them!

    yes it possible some people don't relies they have a problem. If you have stage 2 temp delta set to 2 deg, what happens is your stage 1 is not enough heat, temps drop until 2 deg than stage 2 comes on. I guess some people don't even feel a 2 deg temp drop.

  • towprotowpro Member
    edited December 2016

    If anybody else calls in with this problem of "Stage 1 max run time (before turning on stage 2)" does not work, reference Ticket 298394. That is the ticket number that Engineering has to look into this problem. Be sure to tell that that is not YOUR ticket, but you have the same symptoms.

  • Caprice96Caprice96 WinnipegMember

    I was on the phone with them for about 2 hours tonight. The tech agreed that something was different this year, but tried to explain it away that the thermostat was learning.

    I was able to discover that mine will turn on the second stage after the 40 mins I have it set for only as long as the temperature delta in more than 0.2 degrees Celsius. I have my thermostat set to 20C. If after running for 40mins the current temp is either 19.8 or 19.9, stage 2 will not engage. If the current temp is 19.7 or less after 40 mins, stage 2 will engage.

    They were willing to downgrade my firmware as well (although only after I mentioned I had found other users experiencing the same problem).

    I was still somewhat hesitant to get downgraded based on your comments that the portal no longer functioned correctly. Can you tell what exactly isn't working correctly for you now on the portal?

    I did reference your ticket number and asked them to join my comments with yours in case others called in with the same issue.

  • towprotowpro Member
    edited December 2016

    only thing I can see that is not working in portal is when system IS running, either phone or web app shows "no equipment is running".

    I have changed temps through web portal since role back, that is still workin
    I have not tried a vacation.

    But with stage 1 never advancing to stage 2 the heater fan run time went way up, I noticed more dust collecting on everything.
    I do have Merv 13 aprilare filter system, but the dust was worse with heater running so long.

Sign In or Register to comment.